State Ind. GS640YBRT Pilot Light/TCO Problem

The Tank State Ind. GS640YBRT Pilot Light/TCO Problem

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #11209
    rhodesbe
    Participant

    You good people may be my last hope. Thanks in advance.

    Here’s the rundown of my problem, and what I’ve done so far:

    My unit is 4 years old and has worked fine unti last 5 weeks or so. Then problem keeping flame lit started.

    My problem has always been that pilot goes out, I’ll relight, burn will last for 4-6 minutes, then WHOOM due to lazy flame the whole thing shuts off cold.

    1. I changed out Gas Control Valve & TCO assembly (Piezo starter, thermocouple, & pilot gas supply tubing). Problem didn’t really improve at all.

    2. I vaccumed out inside of combustion chamber & brush cleaned ceramic plate under burner assembly. Cleaned up some rusty flaky garbage from inside chamber, & some rust color dust from under ceramic plate, but unit sits inside drip pan and don’t really think it was too dirty. Flame burns mostly blue, but wanders lazy yellow during burn cycle. Burn cycle ends suddenly with WHOOM. Everything shuts off cold.

    3. I checked draft both top & bottom. Good positive draft noted on flue atop unit, & under unit where draw air is taken.

    Pilot relights easily enough, sometime I have to hold knob for a minute or two but once I get burn cycle started it burns blue & strong for 4 – 6 minuts before it shuts down. If I stay on top of the pilot outages, I can eventually heat water up to 130 – 140 degree range through relights.

    I’m getting tired of relighting the heater 10 times to get water passable enough to shower with. I’ve tried all the troubleshooting tips given by manufacturer, and still the ‘failure mode’ of a sudden shutdown is occuring. Chamber is cleaned, ceramic intake is clean, good strong blue burn cycle, then WHOOM it all shuts down quick.

    Any ideas for me? I’m too stubborn to admit defeat yet. 🙁

    #11210
    Ej
    Participant

    How are you cleaning the flame arrestor if the heater is inside a pan? I find these impossible to clean properly. Surely the flame switch is dropping out due to the lack of fresh air. Also the radiation shield inside the burner chamber could be tweaked blocking the fresh air intake. It should be 1/2 inch off the bottom all the way around. Take a air compressor and blow through the flame arrestor from the inside to outside.

    #11214
    rhodesbe
    Participant

    I have taken a large cable tie – it’s a big black one, about .5″ wide and 24″ long and daisy chained a series of ‘swiffer duster’ pads long it, and run it repeatedly under in the narrow gap between the bottom of the ceramic flame arrestor and the drip pan.

    I also broke down today a bought a long condesor coil type brush rammed than thing into the gap and tried to get things clean. I don’t know if either method worked well enough to clean anything, but it seemed to work.

    I also took several nuts and spaced them along the warped base plate to try to facilitate better air flow inside the air chamber. It was warped like a ‘cookie pan’ like other pages have suggested in these pages, but I tried to achieve the uniform 1/2″ gapping suggested.

    Still the same problem. Runs for a while, then shuts off. I appreciate the help, no matter the frustration I’m having

    #11215
    Ej
    Participant

    Remove the burner and carefully remove the view window. Place the burner back in. Set up a fan in front of the heater with a very light air movement. Give it a try. If it works then your flame arrestor is still plugged.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.
Water Heater Rescue

You cannot copy content of this page