Rotten Eggs smell and black 'stuff'

The Tank Rotten Eggs smell and black 'stuff'

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #24333
    Cougar281
    Participant

    My sister recently bought a house out near me, and we’ve been having an issue with a rotten egg smell in the water. She seems to think that there is some smell in the cold water, but I haven’t noticed that myself – it seems to me to be coming from the hot water only. I think that it’s this issue, and it seems like doing the Peroxide treatment helps it. This was noticed pretty much right away in the main house, but the secondary house on the property did not exhibit the issue at first, but it seemed to appear after a few weeks.

    A Little back story. The property was renovated and was on the market for a while – I believe overall, it was vacant for probably two years, and on the market for around a year when it was purchased. The main house has a 50 gallon Richmond electric heater, and the secondary house has a 40 gallon Rheem electric (I think they are in fact both made by the same factory as they both appear identical externally, right down to the anode being buried under 2″ of foam insulation). The main house had the water heater on keeping the water hot for who knows how long – I’d assume as long as it was on the market. The secondary house, however, had the power to the water heater off at the time the house was purchased, so I would guess that it was almost never powered on. I suspect this is why the main house had the smell problem from the beginning and the secondary house did not – I imagine heat plays into the reaction that creates the smell. Both water heaters are new – made within the last few years, and both buildings are fed by the same well. I suspect that either a powered anode or an aluminum/zinc anode will address the issue – main problem in the main house is there is not enough overhead clearance to get it out by probably 3 or 4 inches – I’ll have to drain it, disconnect it and tilt it to remove it.

    But that leaves the black stuff. There are no rubber or flexible hoses – only copper an PEX. Taking out the T/P valve (The only way I could dose it with peroxide since I couldn’t get the anode out), the inside is coated with the black ‘slime’, as was the wonky plastic drain valve that I replaced with a brass nipple and ball valve. Any time the water heater is partially drained or there’s some kind of turbulence, all manner of black crud ends up coming out of the faucets.

    I think the rotten egg issue is identified, but any thoughts on the black crud that seems to be coming from the water heater?

    #24335
    Larry Weingarten
    Participant

    Hello, I usually try to give the least expensive fix for a problem, but in this case, I’ll suggest more expensive actions that fix the design problem as well. The bigger heater should never have been shoe-horned into such a tight space, as you can’t service it now. So, I’d either get a shorter glass-lined tank or a Marathon tank, (has no anode) to replace the existing one. It’s hard to know what’s happened inside of a tank that’s been sitting stagnant for three years. There may be little life left in it as the water has been made more conductive with all the bacteria growing in it. More conductive water speeds anode consumption.

    If there is room to service the smaller heater, then putting a good drain valve, curved dip tube and an aluminum/zinc anode in it will likely do the trick… if the water is used consistently. If it sits unused for periods of time, a powered anode or a Marathon tank are good options. 😎
    Yours, Larry

    #24336
    Cougar281
    Participant

    I haven’t pulled the anode in the smaller one, but I did take a peek inside with an endoscope when I treated it with peroxide and best I could tell, it seemed to be perfect. The Anode on the bigger one I was able to get most of the way out – There was probably only 3 or 4 inches in the tank when the top hit the HVAC ducting. There was some pitting and deposits on it, but I would guess it was still probably 90-95% (unlike the anode in my now-replaced water heater that was totally gone). Since the anode is still there and not even close to used up, would the condition of the tank still be suspect?

    #24337
    Larry Weingarten
    Participant

    Hello, Rheem puts a resistor in their anode to slow it down and sometimes it works too well and the rod quits working effectively. This is called passivation. The rod can look nearly new but not do any good, so there remains the possibility of tank damage.

    Another thought would be to install a powered anode in the bigger tank and flushing parts as well. This would involve tipping the tank to get the work done… but the parts could be reused should the tank fail.

    Being a service plumber, I like to set things up to be easily maintained, so keeping it as is just goes against the grain a bit, but I certainly understand the desire to save money 😉
    Yours, Larry

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.
Water Heater Rescue

You cannot copy content of this page