electric water heaters

The Tank electric water heaters

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #9749
    blackknight
    Participant

    ok… i just bought my first home and it has a electric water heater. i filled the tank, checked the breaker box,and nothing. any advice would be very cool.

    it is a 50 gal. i have no clue how old. whole house is electric so no gas…

    thanks in advance…. also we are considering getting a 80 gal. so any advice on installation would also be really cool…

    #9750
    Randy Schuyler
    Keymaster

    Did you turn on the power before or after you filled the tank? If before, then you fried the heating elements. If after, then next, you’ll want to turn off power, open the upper element hatch, and hit the red reset button. You’ll probably have to remove some insulation and such first. Put it back as you found it. Don’t forget to turn the power back on.

    If the heater still won’t work, or works briefly and shuts down, then there is a walk-through at Electric Water Heater Issues in Tanklets, for which there is a link at the top of The Tank topics page, for troubleshooting electrics. You need to know how to use a multimeter for that. If you don’t, call a plumber.

    Randy Schuyler

    #9769
    blackknight
    Participant

    well… big surprize! the thing just started working today!!! i now know why people should check thing themselves instead of taking someones word…. thanks alot folks for your help.

    #9880
    blackknight
    Participant

    ok up date time… hee hee, it’s dead again! turns out the element is junk. this is crazy. 😕 i changed it but now its leaking hot water from the t/p valve. agh!! how do i fix this new issue… whatever advice would be a relife. thanks folks…

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.
Water Heater Rescue

You cannot copy content of this page