Brand New Richmond Direct Vent Water Heater Will Not Start

The Tank Brand New Richmond Direct Vent Water Heater Will Not Start

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #14578
    zooeyhall
    Participant

    I just installed my new 40 gallon Richmond Direct Vent LP water heater.

    When I turn on the power, the LEDs on the diagnostic board all come on, the controller clicks twice, the blower fan starts and runs for about 1.5 sec–and then everything shuts-off.

    The LED’s on the diagnostic board turn off, and I am not getting any error codes.

    I have double checked the wiring and plugs–unplugged them to make sure no pins were bent or not making contact. They all look ok to me.

    I disconnected the ducting, to see if it was making the unit think there was an obstruction. No good.

    I ran a fan aimed at the heater to make sure there were no flammable vapors triggering the sensor. Also–it is supposed to flash a code if there are vapors present. Again, once the unit shuts-down all the LED’s go off. I’m not getting any error codes.

    Checked the littler rubber hose that goes from the blower plenum to the pressure/vacuum switch to see if it was kinked or disconnected.

    No good trying to manually check the pressure/vacuum switch (if that’s causing the problem). Richmond only seems to sell it as part of the complete blower assembly.

    So—any advice on what else I should check? I sure am not looking forward to a cold shower tonight.

    #14582
    zooeyhall
    Participant

    Problem has been solved. I called Richmond technical support, and they gave me the answer right away.

    Apparently, the thermostat gas control has to be “activated” upon first use.

    This procedure applies to the White-Rodgers controls. Richmond also uses a Robertshaw control which uses a different procedure.

    1) Turn on power to water heater

    2) Immediately press and hold the two temperature adjustment arrows (left and right arrows) simultaneously, until leftmost LED turns on

    3) Release temperature adjustment buttons.

    4) Press right temperature adjustment arrow 3 times. Water heater should start.

    The tech support person I talked to said the directions were in the manual. I double checked the Use and Care Guide I received, cover to cover, and I couldn’t see anything regarding these particular instructions. So I hope my post will help others who run into a similar problem.

    Apparently, this procedure only needs to be done when first starting up a new water heater, or after replacing the control with a new one.

    #14584
    Larry Weingarten
    Participant

    Hello: Thanks for posting. Sharing info is what this place is all about 😎

    Yours, Larry

    #14585
    SnowyNorth
    Participant

    I have a PDF of the White-Rodgers Intelli-Vent Control Information which a lot of trouble shooting info. If anyone would like a copy, they can PM me with an email address.

    Chuck

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.
Water Heater Rescue

You cannot copy content of this page